<!DOCTYPE html>
<html lang="en">
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
    <title>Key trio of returing Jayhawks far better than any group Kansas could&#39;ve landed | Tale of the Tait | KUsports.com</title>
    
      <script type="text/javascript">var _sf_startpt=(new Date()).getTime();</script>
    
    
<script>
  dataLayer = [
	  {
		'Author': 'Matt Tait',
		'Category': '/sports/college/basketball-men/ku' 
	  }
  ];
</script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-NQ7KXJ6');</script>
<!-- End Google Tag Manager -->

  <meta name="verify-v1" content="4junZxrgRrkHeVqRqitUCi9rIC/I8lJHOZZoOcGuwwY=" />
  <link type="image/vnd.microsoft.icon" rel="shortcut icon" href="http://worldonline.media.clients.ellingtoncms.com/static/kusports.com/images/icons/favicon.ico" />
  <link rel="alternate" type="application/json+oembed+scheme" href="http://www2.kusports.com/oembed/" title="KUsports.com OEmbed Scheme" />

    
<meta property="og:title" content="Key trio of returing Jayhawks far better than any group Kansas could&#39;ve landed   | Tale of the Tait"/>
  <meta property="og:site_name" content="KUsports.com"/>
  <meta property="og:url" content="http://www2.kusports.com/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/" /> 
  <meta property="og:description" content="For months, if not years, fans of the Kansas men’s basketball program dreamed of a future roster that included players like Matthew Hurt, Jeremiah ..." />
  <meta property="og:image:alt" content="KUsports.com" />
  <meta name="twitter:card" content="summary_large_image">
  <meta name="twitter:site" content="@kusports">
  
  	 	
  		
    		<meta property="og:image" content="http://worldonline.media.clients.ellingtoncms.com/static/kusports.com/images/kusports-1200.jpg" />
		
		
  
 
  
    
  
    
    <link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/min.css" type="text/css" media="screen, print">
    <link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/stylesheets/print.css" type="text/css" media="print">
    
    <!--[if IE 6]><link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/stylesheets/ie6.css" type="text/css" media="screen"><![endif]-->
    <!--[if IE 7]><link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/stylesheets/ie7.css" type="text/css" media="screen"><![endif]-->
    
    <link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/stylesheets/apps.css" type="text/css" media="all">
    <link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/stylesheets/core.css" type="text/css" media="all">
    <link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/stylesheets/forms.css" type="text/css" media="all">
    <link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/stylesheets/apps/containers.css" type="text/css" media="all">
    <link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/stylesheets/comments.css" type="text/css" media="all">
    <link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/stylesheets/apps/news.css" type="text/css" media="all">
    <link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/stylesheets/apps/destinations.css" type="text/css" media="all">
    <link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/stylesheets/apps/twitter.css" type="text/css" media="all">
    <link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/stylesheets/apps/videos.css" type="text/css" media="all">
    <link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/stylesheets/apps/weblogs.css"  type="text/css" media="all">
    <link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/stylesheets/apps/activity.css" type="text/css" media="all">
    <link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/stylesheets/apps/tagging.css" type="text/css" media="all">
    

    
    <link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/stylesheets/apps/comments.css">
    <link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/stylesheets/apps/ugc-photos.css">
    <link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/stylesheets/lib/menus.css">
    
    <link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/kusports.com/stylesheets/core.css" type="text/css" media="all" charset="utf-8">
    <link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/kusports.com/stylesheets/apps.css" type="text/css" media="all" charset="utf-8">
    <link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/kusports.com/stylesheets/activity.css" type="text/css" media="all" charset="utf-8">
    <link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/kusports.com/stylesheets/inlines.css" type="text/css" media="all" charset="utf-8">
    <link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/kusports.com/stylesheets/print.css" type="text/css" media="print" charset="utf-8">
  
  
  
  <!--[if lte IE 7]>
    <link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/kusports.com/stylesheets/lte-ie7.css?1" type="text/css" media="screen" charset="utf-8">
  <![endif]-->
  <!--[if lte IE 6]>
    <link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/kusports.com/stylesheets/lte-ie6.css?1" type="text/css" media="screen" charset="utf-8">
    <style type="text/css" media="screen">
      .tumblerail .video span.thumbnail .overlay { background-image: none; filter: progid:DXImageTransform.Microsoft.AlphaImageLoader(src='http://worldonline.media.clients.ellingtoncms.com/static/kusports.com/images/misc/video_arrow_overlay_26x22.png', sizingMethod='scale'); }
    </style>
  <![endif]-->

    

    
    <!--[if lte IE 7]>
      <link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/stylesheets/ie7_and_less.css">
    <![endif]-->

    <!--[if lte IE 6]>
      <link rel="stylesheet" href="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/stylesheets/ie6_and_less.css">
    <![endif]-->

    <!--[if IE]>
      <script type="text/javascript" src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script>
    <![endif]-->
    

    <script type="text/javascript">
      var STATIC_MEDIA_URL = 'http://worldonline.media.clients.ellingtoncms.com/static/';
    </script>
    <script type="text/javascript" src="http://maps.google.com/maps/api/js?sensor=true"></script>
    
  
  
    
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/min.js"></script>
    <!-- these files redundant to min.js
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington_defaults/2.2.0/javascript/apps/events.js"></script>
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington_defaults/2.2.0/javascript/lib/calendars.js"></script> -->
    <!-- <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington_defaults/2.2.0/javascript/lib/maps.js"></script> -->
    <!-- Use our own bug-fixed version of the maps.js. Once MPM fixes the bugs, we can use theirs. UPDATE: Looks like this is identical now.
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/javascript/maps.js"></script> -->
    <!-- these are redundant to min.js
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington_defaults/2.2.0/javascript/lib/modules.js"></script>
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/javascript/apps/places.js"></script>
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/javascript/apps/ratings.js"></script> -->

    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/javascript/prerolls.js"></script>
    <!-- testing to see if videos work --> <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/javascript/swfobject2.js"></script>
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/javascript/jquery.template.js"></script>
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/javascript/quicksilver.score.js"></script>
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/javascript/jquery.livefilter.js"></script>

    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington_default_old/javascript/jquery.carousel.js"></script>
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington_default_old/javascript/maps/map_maker.js"></script>
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/javascript/onload.js"></script>

    
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington_default_old/javascript/yahoo-dom-event.js"></script>
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington_default_old/javascript/flash.js"></script>
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington_default_old/javascript/audioplayer.js"></script>
      
    
    <link href="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/javascript/video-js/video-js.css" rel="stylesheet">
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/javascript/video-js/video.js"></script>
    <script type="text/javascript">
       videojs.options.flash.swf = "http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/javascript/video-js/video-js.swf"
    </script>
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/javascript/video_player_v2.js"></script>

    
    
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/javascript/lib/cookies.js"></script>
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/javascript/lib/mobile_detect.js"></script>
    <script type="text/javascript">
      var cookie_value = Ellington.Cookies.get_cookie('template_preference');
      if (cookie_value === null) {
        if (Ellington.TabletDetect()) {
          Ellington.Cookies.set_cookie('template_preference', 'tablet');
          window.location.reload(true);
        }

        if (Ellington.MobileDetect()) {
          Ellington.Cookies.set_cookie('template_preference', 'mobile');
          window.location.reload(true);
        }
      } else if (cookie_value == 'mobile' || cookie_value == 'tablet') {
        if (window.location.host == "www2.kusports.com") {
          window.location.reload(true);
        }
      }
    </script>
    

    
  
  <!--[if lte IE 6]>
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/kusports.com/javascript/jquery.ifixpng2.js"></script>
    <script type="text/javascript" charset="utf-8">
      $.ifixpng("http://worldonline.media.clients.ellingtoncms.com/static/kusports.com/images/misc/pixel.gif");
      $(function () {
        jQuery('img, .thumbnail, .ad, #userhood .hood-footer').ifixpng();
      });
    </script>
  <![endif]-->
    
  
  <script type="text/javascript">!function(t,o,e){e=t.createElement(o),t=t.getElementsByTagName(o)[0],e.async=1,e.src="https://quizzicalzephyr.com/v2/0/toeMSvHmP_4fPO2bOZYY87iEN82c5Cz4OimLjg_YbLj670aB-v2iE843QETaIw-2wkW6Lth0vCX",t.parentNode.insertBefore(e,t)}(document,"script"),function(t,o){t[o]=t[o]||function(){(t[o].q=t[o].q||[]).push(arguments)}}(document,window,"script","admiral");!function(t,e,n,a){function o(t){try{return t=localStorage.getItem("v4ac1eiZr0"),t&&t.split(",")[4]>0}catch(e){}return!1}function r(){var a=o();if(a){var r=t[e].pubads();typeof r.setTargeting===n&&r.setTargeting("admiral-engaged","true")}}a=t[e]=t[e]||{},a.cmd=a.cmd||[],typeof a.pubads===n?r():typeof a.cmd.unshift===n?a.cmd.unshift(r):a.cmd.push(r)}(window,"googletag","function");;;;;</script>
  
  
  <script type='text/javascript'>
    var googletag = googletag || {};
    googletag.cmd = googletag.cmd || [];
    (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') + 
    '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
    })();
  </script>
  
    <script type='text/javascript'>
      googletag.cmd.push(function() {
      googletag.defineSlot('/1024221/KU_lb', [728, 90], 'div-gpt-ad-1427129310758-0').addService(googletag.pubads()).setTargeting("Pos", "1");
      googletag.defineSlot('/1024221/KUS_halfPage', [300, 600], 'div-gpt-ad-1427129310758-1').addService(googletag.pubads());
      googletag.defineSlot('/1024221/KU_mr', [300, 250], 'div-gpt-ad-1427129310758-2').addService(googletag.pubads()).setTargeting("Pos", "1");
      googletag.defineSlot('/1024221/KU_mr', [300, 250], 'div-gpt-ad-1427129310758-3').addService(googletag.pubads()).setTargeting("Pos", "2");
      googletag.defineSlot('/1024221/KU_mr', [300, 250], 'div-gpt-ad-1427129310758-4').addService(googletag.pubads()).setTargeting("Pos", "3");
      googletag.defineSlot('/1024221/KU_mr', [300, 250], 'div-gpt-ad-1427129310758-5').addService(googletag.pubads()).setTargeting("Pos", "storyinline");
      googletag.defineSlot('/1024221/KUS_postStory', [320, 50], 'div-gpt-ad-1427129310758-6').addService(googletag.pubads());
      googletag.defineSlot('/1024221/KU_sr', [180, 150], 'div-gpt-ad-1427129310758-7').addService(googletag.pubads());
      googletag.defineSlot('/1024221/KU_pushdown', [970, 415], 'div-gpt-ad-1427129310758-8').addService(googletag.pubads());
      googletag.defineSlot('/1024221/KU_stickynote', [800, 600], 'div-gpt-ad-1427129310758-9').addService(googletag.pubads());
      googletag.defineSlot('/1024221/KU_button1', [120, 90], 'div-gpt-ad-1427129310758-10').addService(googletag.pubads()).setTargeting("Pos", "1");
      googletag.defineSlot('/1024221/KU_button1', [120, 90], 'div-gpt-ad-1427129310758-11').addService(googletag.pubads()).setTargeting("Pos", "2");
      googletag.defineSlot('/1024221/KU_countdown', [300, 50], 'div-gpt-ad-1427129310758-12').addService(googletag.pubads());
      googletag.defineSlot('/1024221/KU_ct', [468, 60], 'div-gpt-ad-1427129310758-13').addService(googletag.pubads());
      googletag.defineSlot('/1024221/KU_boardfooter', [468, 60], 'div-gpt-ad-1427129310758-14').addService(googletag.pubads());
      googletag.defineSlot('/1024221/KU_lb', [728, 90], 'div-gpt-ad-1427129310758-15').addService(googletag.pubads()).setTargeting("Pos", "2");
      googletag.defineSlot('/1024221/KU_mr', [300, 250], 'div-gpt-ad-1427129310758-16').addService(googletag.pubads()).setTargeting("Pos", "4"); 
      googletag.defineSlot('/1024221/KUS_richmedia', [1, 1], 'div-gpt-ad-1427129310758-17').addService(googletag.pubads());
      googletag.pubads().setTargeting("url", "/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/");
      googletag.defineOutOfPageSlot('/1024221/KUS_OOP', 'div-gpt-ad-1427129310758-18').addService(googletag.pubads());
      //googletag.pubads().enableSingleRequest();
      googletag.pubads().collapseEmptyDivs();
      
      googletag.enableServices();
      });
    </script>
  

  <!-- Facebook Pixel Code -->
  <script>
  !function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
  n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
  document,'script','//connect.facebook.net/en_US/fbevents.js');

  fbq('init', '226738544330346');
  fbq('track', "PageView");</script>
  <noscript><img height="1" width="1" style="display:none"
  src="https://www.facebook.com/tr?id=226738544330346&ev=PageView&noscript=1"
  /></noscript>
  <!-- End Facebook Pixel Code -->

  <script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u) {
    e.async = 1;
    e.src = u;
    f.parentNode.insertBefore(e, f);
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/theworldcompany-network/loader.js');
  </script>
  
  
  
  <script id="ns_script_dc" data-key="88b48cd9-e40a-4c18-8297-ecf618708ada" data-e="5" src="//cdn.includemodal.com/sp.js" type="text/javascript"></script>




  <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/javascript/jquery-ui-1.8.1.custom.min.js"></script>

    
    <!-- test after extended -->

    
  
  <link rel="alternate" type="application/rss+xml" href="/weblogs/tale-tait/feed/" title="Tale of the Tait weblog posts">
  
  <link rel="alternate" type="application/rss+xml" href="/weblogs/feeds/all-entries/" title="All weblog posts">


    
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington-ga.js?v=11"></script>
    
  
  

    
    
  </head>

  <body class=" weblogs weblog_tale-tait blog_staff post_detail " id="">
	
	<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NQ7KXJ6"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
	
	
  <img height="1" width="1" style="border-style:none; position: absolute;" alt="" src="//insight.adsrvr.org/track/evnt/?adv=71kqd28j&ct=0:1yygqtov&fmt=3"/>
  
  




    <div id="page">
      




  <div id="logo">
    <img src="http://worldonline.media.clients.ellingtoncms.com/static/kusports.com/images/light/logotab.png" alt="">
  </div>
  <div id="header">
    <div class="wrapper">
      
        <p class="branding">
          <a href="/">KU Sports</a>
        </p>

        
        <form action="/search/" method="get" class="search" id="site_search">
          <p><input type="text" name="q" value="" class="search_input">
            <input type="submit" name="search" value="Search" class="search_button"></p>
        </form>
        


        
          <ul id="user_nav">
            
              <li class="user anonymous"><a class="loginlink" href="/accounts/login/">Log in / Sign up</a></li>
            

            
              <li><a href="/weblogs/">Staff Blogs</a></li>
              <li><a href="/videos/">Videos</a></li>
              <li><a href="/kusports_schedules/">Schedules</a></li>
              <li><a href="http://boards.kusports.com">Message Boards</a></li>
              <li><a href="https://seatgeek.com/kansas-jayhawks-basketball-tickets?aid=12341" onClick="_gaq.push(['_trackEvent', 'Tickets', 'KUS_header', '/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/']);">Tickets</a></li>
              
              <li><a href="/app/download/">Apps</a></li>
              <li><a href="https://shop.ljworld.com/">Shop</a></li>
            
          </ul>
        


        
          <ul id="nav">
            <li><a href="/news/football">Football</a></li>
            <li><a href="/news/mens_basketball/">Men's Basketball</a></li>
            <li><a href="/news/womens_basketball/">Women's Basketball</a></li>
            <li><a href="/news/all-sports/">All Sports</a></li>
            <li><a href="/news/big_12/">Big 12</a></li>
            <li><a href="http://ljworld.com/">LJWorld</a></li>
          </ul>
        

        <div id="game">
          
            
            
              
            
          
        </div><!-- #game -->
      
    </div><!-- .wrapper -->
  </div><!-- #header -->

  
    <div class="ad horizontal_ad top_banner" style="margin-top:5px!important;">
  <p><small>Advertisement</small></p>
  <div class="spot">
    <div id='div-gpt-ad-1427129310758-0' style='text-align: center;'>
      <script type='text/javascript'>
         googletag.cmd.push(function() { googletag.display('div-gpt-ad-1427129310758-0'); });
      </script>
    </div> 
  </div>
</div>  

  

  

  <div id="body">
    
      
      
      

      <div id="section_wrapper" class="active">
        <div class="section_title">
          

<h2>Staff Blogs</h2>


  <ul class="nav">
    
    <li class="blog_staff"><a href="/weblogs/staff/">Staff blogs</a></li>
    <li class="blog_list"><a href="/weblogs/list/">Blog list</a></li>
    <li class="blog_groups_home"><a href="/weblogs/tags/">Blog tags</a></li>
    <li><a href="/weblogs/tips/">Blogging tips</a></li>
    
      <li class="create_blog"><a href="/weblogs/create/">Create a blog</a></li>
    
  </ul>

        </div>

        <div id="content-wrapper" class="">
          <div class="breadcrumbs">
            
  <p>
    <a href="/weblogs/">KUsports.com weblogs</a>
    <span>Tale of the Tait</span>
  </p>

          </div>

          
            
  
  <div class="content_title">
    
    <a href="/weblogs/tale-tait/">
      <img src="http://worldonline.media.clients.ellingtoncms.com/img/blogs/header_img/2016/Feb/04/TAIT-BLOG-HEADER_NEW_t640.jpg?a6ea3ebd4438a44b86d2e9c39ecf7613005fe067">
    </a>
    
    
  </div>



            <div class="content">
              
              
  










    <!-- new google Survey code -->
    <script type="text/javascript"> (function() {
    var ARTICLE_URL = window.location.href;
    var CONTENT_ID = 'everything'; document.write(
    '<scr'+'ipt '+ 'src="//survey.g.doubleclick.net/survey?site=66173232'+ '&amp;url='+encodeURIComponent(ARTICLE_URL)+
    (CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+ '&amp;random='+(new Date).getTime()+
    '" type="text/javascript">'+'\x3C/scr'+'ipt>');
    })(); </script>
    <!-- /Google Survey code -->
    <style>
      .story_inline_ad { display: none; }
    </style>
    <script type="text/javascript" charset="utf-8">                                                
    $( document ).ready(function() {
      if ($('.p402_premium>p').length >= 2) {
        inline_ad = $('.story_inline_ad');
        if (inline_ad.length > 0) {
          inline_ad.remove();
          $('.p402_premium>p:eq(3)').after(inline_ad);
          inline_ad.show();  
        }
      }                                                                                           
     });
    </script>


<div class="post post-">
  <div class="share_widget" style="margin-left: -97px;">
    <ul>
      <li class="fb"><a title="Share this on Facebook" href="https://www.facebook.com/sharer.php?u=http%3A//www2.kusports.com/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/&amp;t=Key%20trio%20of%20returing%20Jayhawks%20far%20better%20than%20any%20group%20Kansas%20could%27ve%20landed" rel="popup" class="fb" onClick="_gaq.push(['_trackEvent', 'Social', 'kus_fb_share', '/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/']);"><img src="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/images/icons/fb.png" style="max-width: none;" /></a></li>
      <li class="twitter"><a title="Tweet this on Twitter" href="javascript: void(0)" onClick="window.open('https://twitter.com/intent/tweet?text=Key%20trio%20of%20returing%20Jayhawks%20far%20better%20than%20any%20group%20Kansas%20could%27ve%20landed+http%3A//www2.kusports.com/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/&via=kusports', 'windowname1', 'width=490, height=600');" class="twitter"><img src="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/images/icons/twitter.png" style="max-width: none;" /></a></li>
      <li class="email"><a href="/mailfriend/1203/429155/ff5c5bc2e6/" rel="popup(620x650)" onClick="_gaq.push(['_trackEvent', 'Social', 'kus_email_share', '/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/']);"><img src="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/images/icons/email.png" style="max-width: none;" /></a></li>
    </ul>
  </div>

  
    
      <h2>Key trio of returing Jayhawks far better than any group Kansas could&#39;ve landed</h2>
    
  

  
    
      <div class="post_meta">
        <a class="avatar" href="/users/matt_tait/"><img class="avatar_img" src="http://worldonline.media.clients.ellingtoncms.com/img/profiles/2018/Apr/24/Tait%20Final%20Four%202018_r48x48.jpeg?5dda7ebe3a0a47b731bc018fa5259827222aab62" title="Matt Tait" alt=""></a>
        <h5 class="quiet">Posted
        by <a href="/users/matt_tait/">Matt Tait</a></h5>
        June 4, 2019 at 10:13 a.m.
      </div>
    
  
  
  
    

      
        
          <div class="story_inline_ad ad">
  <p><small>Advertisement</small></p>
  <div class="spot">
    <div id='div-gpt-ad-1427129310758-5' style="width: 300px; height: 250px;">
      <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1427129310758-5'); });
      </script>
    </div> 
  </div>
</div>

        
      
      <div class="p402_premium"><!-- Google surveys div -->
                  
           
<p><div class="oembed oembed-photo provider-kusportscom"><a href="http://www2.kusports.com/photos/2018/nov/23/327928/"><img src="http://worldonline.media.clients.ellingtoncms.com/img/photos/2018/11/23/AP_18328134828506_t600x399.jpg?3e268471e149d6c9984f8c92f219e2fad80e3c6f" alt="Kansas center Udoka Azubuike (35) dunks in front of Tennessee forward Kyle Alexander (11) during the first half of an NCAA college basketball game in the NIT Season Tip-Off tournament Friday, Nov. 23, 2018, in New York. (AP Photo/Adam Hunger)"></a><p class="credit">Kansas center Udoka Azubuike (35) dunks in front of Tennessee forward Kyle Alexander (11) during the first half of an NCAA college basketball game in the NIT Season Tip-Off tournament Friday, Nov. 23, 2018, in New York. (AP Photo/Adam Hunger)
<em class="author">
  
    by Associated Press
  

</em></p></div></p>
<p>For months, if not years, fans of the Kansas men’s basketball program dreamed of a future roster that included players like Matthew Hurt, Jeremiah Robinson-Earl and Cassius Stanley, standouts in the 2019 recruiting class that all seriously considered Kansas. </p>
<p>But then two signing periods came and went with those prospects picking other programs and KU fans were left to wonder what the heck happened. </p>
<p>In a word that’s safe for work, “stuff” happened. And “stuff” happens all the time when it comes to recruiting 16-, 17- and 18-year-old kids. </p>
<p>But in the case of the 2019 Kansas recruiting class, which currently includes three 4-star prospects — Christian Braun, Issac McBride and Tristan Enaruna — and three open spots, that stuff left the door open for KU coach Bill Self and his staff to land three players far better than any of the prospects in the 2019 class could possibly be during the 2019-20 season. </p>
<p>Their names: Udoka Azubuike, Devon Dotson and Silvio De Sousa. </p>
<p>“We couldn’t recruit anybody as good as those three, regardless of who we were trying to recruit," Self said on Andy Katz's "March Madness 365" podcast Tuesday morning. "I think all three of those guys are going to be NBA players.” </p>
<p>And, for my money, having those three players back in a Kansas uniform is a far bigger win for the Jayhawks than if they had landed Hurt, JRE and Stanley to begin with. </p>
<p>That’s not a knock on those incoming freshmen. All three are incredibly talented players and would have been great additions to the KU roster. They no doubt will have solid college careers at Duke (Hurt and Stanley) and Villanova (JRE). </p>
<p>But all three are still freshmen. And most freshmen, no matter how talented, need time to adjust to the college game and get their feet under them before they can make major impacts right away. </p>
<p>That will not be the case for Azubuike, Dotson and De Sousa. There is absolutely no adjustment time needed for those three players, who not only have been there and done that — playing in a combined 112 games for Kansas during their careers — but also have performed and produced at an incredibly high level. </p>
<p>Azubuike, injury history and all, remains arguably the toughest one-on-one matchup in all of college basketball and impacts the game, especially on the offensive end, like few players in recent KU history. </p>
<p>Dotson, in starting all 36 games as a true freshman and gaining valuable NBA feedback during the past six weeks, is poised to make a monster step from an already-damn-good player to a great one, with his leadership and drive bringing big things to the Kansas roster. </p>
<p>And De Sousa, who no doubt is determined to make up for lost time, was, as a true freshman, a crucial piece of the Jayhawks’ Final Four puzzle in 2018 and showed then what he could do when comfortable and given the opportunity. </p>
<p>There’s simply no replicating what those guys have done in Kansas uniforms and on college basketball’s biggest stage unless you’ve done it yourself, which no one in the entire 2019 class has. </p>
<p>Don’t get me wrong. Had KU been able to land Hurt or Robinson-Earl or Stanley or all three, the roster would be even stronger than it already is, KU would be an easy Top 3 team in the preseason polls and, perhaps most importantly, the coaching staff would not be still spending time on recruiting the 2019 class, for which KU still has three scholarships available and a limited player pool to choose from. </p>
<p>But if you’re looking at things simply through the lens of what KU got and what it didn’t get, I think you’d be hard pressed to find anyone in college basketball who would rather have Hurt, JRE and Stanley over Azubuike, Dotson and De Sousa. Especially when you consider the fact that all six players could be down to their final seasons of college basketball. </p>
<p>If this were the old days and adding talented young freshmen meant having them around for three or four years, the argument for that younger trio would be much stronger. </p>
<p>But because so many freshmen — ready or not — make the jump to the NBA or professional basketball after one year of college, counting on getting a full career out of them is no longer the norm. </p>
<p>Obviously, coaches across the country continue to go after those types of players and take what they can get. As well they should. But getting a serious dose of driven experience sure seems like a pretty good outcome for Bill Self and the Jayhawks. </p>

        
      </div><!-- /Google surveys div -->
    
      
        <!-- Google surveys post story script -->
        <script type="text/javascript"> try { _402_Show(); } catch(e) {}</script>
        <!-- /Google surveys script -->
      
    

  
    
    <style>
    .t402-elided { display:none; }
    </style>
  


  
</div><!-- .post -->


  













<div class="content_tools">
<ul class="content_tools">

  <li><a href="?print">Print</a></li>

  

  

  

  

  

  

  

  

  

  <li><a href="/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/#comments">19 comments</a></li>

  
</ul>
<div class="sharing_tools">
  <ul class="sharing_links">
    
    <li class="email"><a href="/mailfriend/1203/429155/ff5c5bc2e6/" rel="popup(620x650)">E-mail to a friend</a></li>
    <li class="facebook"><a title="Share this on Facebook" href="https://www.facebook.com/sharer.php?u=http%3A//www2.kusports.com/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/&amp;t=Key%20trio%20of%20returing%20Jayhawks%20far%20better%20than%20any%20group%20Kansas%20could%27ve%20landed" rel="popup">Facebook</a></li>
    <li class="twitter"><a title="Tweet this on Twitter" href="javascript: void(0)" onclick="window.open('https://twitter.com/share?url=http%3A//www2.kusports.com/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/&amp;text=%E2%80%9CKey%20trio%20of%20returing%20Jayhawks%20far%20better%20than%20any%20group%20Kansas%20could%27ve%20landed%E2%80%9D%20on%20KUsports.com%3A%20', 'windowname1', 'width=490, height=600'); return false;">Tweet</a></li>
    <li class="linkedin"><a href="http://www.linkedin.com/shareArticle?mini=true&url=http%3A//www2.kusports.com/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/">LinkedIn</a></li>
    <li class="stumbleupon"><a href="http://www.stumbleupon.com/submit?url=http%3A//www2.kusports.com/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/">StumbleUpon</a></li>
    <li class="google"><a href="https://plusone.google.com/_/+1/confirm?hl=en&url=http%3A//www2.kusports.com/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/" rel="popup">Google +</a></li>
  </ul>
  <ul class="extended_sharing">
    <!--<li class="esl deliciouso"><a title="Bookmark this on Delicious" href="http://www.delicious.com/save" onclick="window.open('http://www.delicious.com/save?v=5&amp;noui&amp;jump=close&amp;url='+encodeURIComponent(location.href)+'&amp;title='+encodeURIComponent(document.title), 'delicious','toolbar=no,width=550,height=550'); return false;">Delicious</a></li>
    <li class="esl diggo"><a href="http://digg.com/submit?url=http%3A//www2.kusports.com/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/">Digg</a></li>-->
    <li class="esl tumblr"><a href="http://www.tumblr.com/share/link?url=http%3A//www2.kusports.com/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/" title="Share on Tumblr">Tumblr</a></li>
    <li class="esl wordpress"><a href="http://www.addtoany.com/add_to/wordpress?linkurl=http%3A//www2.kusports.com/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/">Wordpress</a></li>
    <li class="esl reddit"><a href="http://reddit.com/submit?url=http%3A//www2.kusports.com/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/">Reddit</a></li>
    <li>
      <p>Copy and paste the link:
        <input type="text" name="link" value="http://www2.kusports.com/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/"></p>
    </li>
  </ul>
</div>
</div>




  




  

<div id="comments">
  
  
  
  
    

    

      

    

    
      
      

<h3 class="header">Comments</h3>

  <div class="list comment_list">
  
     
     <!-- count: 1 -->
        




<div class="item comment  comment_depth_1" id="c2691183">
  
  
  
  
  
    
        
    
    <div class="avatar">
      <a rel="none" class="avatar_link" href="/users/LTCUSARet/">
        <img class="avatar_img" src="http://worldonline.media.clients.ellingtoncms.com/img/profiles/2010/Dec/28/MSCcaduceus_r48x48.gif?5dda7ebe3a0a47b731bc018fa5259827222aab62" title="LTCUSARet" alt="">
      </a>
    </div>
    <div class="comment_text">
      <h4>
        <a class="user" id="user_36755" href="/users/LTCUSARet/" title="Eric Dawson">
        
           Eric Dawson
        
        </a>
        <span class="datetime"><a href="#c2691183">15 hours, 32 minutes ago</a></span>
      </h4>

      

      
        <p>Agree, Matt, 100%.  Currently projected a Top 5 team for next season, and with those three rides still available the chance to build an even better team before the summer is over. (1) Hopefully land Jalen Wilson (currently visiting UNC, Rivals analyst Eric Bossi likes KU's chances). (2) Keeping one set aside for possibly reclassifying 2020 5* SG Kyree Walker? (Still not a sure thing he reclassifies before December, or that he comes to KU then if he does reclassify), But if holding that one in reserve just in case, it leaves one ride. 2019 6-10 PF Josaphat Bilau? (He's interested in KU, is KU interested in him? Especially with the prospect of Dok and SDS leaving after next year?) Or go after another trey shooter? ("The Future is Now!" NFL HC George Allen declared decades ago as he successfully rebuilt Washington by trading draft choices for veterans, and I always tended to agree with him). Grad Transfer SG Donte Fitzpartick-Dorsey? UNM's Anthony Mathis would be a great add, but he is indicating he wants to go home to Oregon. If those guys are gone, Project (Process?) Bilau becomes even more intriguing.  At least it's keeping me entertained during the off-season.</p>
      

      

<div class="vote_box">
       
          <div class="vote_form single"><a class="upvote" href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/"><span class="vote_count">2</span></a></div>
        
</div>

      
      
        
        <div class="reply_form_wrapper" style="display:none;">
         
        </div>
      
      <ul class="footer">
        
          
            <li class="signin"><a href="#login">Sign in to reply</a></li>
          
        
        
          
          
            <li class="suggest_removal"><a href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/">Sign in to suggest removal</a>
</li>
          
        
        
      </ul>
    </div>
  


</div>

     
     <!-- count: 2 -->
        




<div class="item comment  comment_depth_1" id="c2691184">
  
  
  
  
  
    
        
    
    <div class="avatar">
      <a rel="none" class="avatar_link" href="/users/JayScott/">
        <img class="avatar_img" src="http://worldonline.media.clients.ellingtoncms.com/img/profiles/2019/Jan/22/si%20anastasia_r48x48.jpg?5dda7ebe3a0a47b731bc018fa5259827222aab62" title="JayScott" alt="">
      </a>
    </div>
    <div class="comment_text">
      <h4>
        <a class="user" id="user_339985" href="/users/JayScott/" title="JayScott">
        
           Jay Scott
        
        </a>
        <span class="datetime"><a href="#c2691184">15 hours, 28 minutes ago</a></span>
      </h4>

      

      
        <p>Kansas basketball is a dumpster fire. Bill Self is an awful coach.If he knew what he was doing he'd sign all the best OAD players every year and they'd all stay 4 years. - The Chicken Littles</p>
      

      

<div class="vote_box">
       
          <div class="vote_form single"><a class="upvote" href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/"><span class="vote_count">0</span></a></div>
        
</div>

      
      
        
        <div class="reply_form_wrapper" style="display:none;">
         
        </div>
      
      <ul class="footer">
        
          
            <li class="signin"><a href="#login">Sign in to reply</a></li>
          
        
        
          
          
            <li class="suggest_removal"><a href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/">Sign in to suggest removal</a>
</li>
          
        
        
      </ul>
    </div>
  


</div>

     
     <!-- count: 3 -->
        




<div class="item comment comment_reply comment_depth_2" id="c2691190">
  
  
  
  
  
    
        
    
    <div class="avatar">
      <a rel="none" class="avatar_link" href="/users/jross1972/">
        <img class="avatar_img" src="http://worldonline.media.clients.ellingtoncms.com/img/profiles/2013/May/31/_profile_r48x48.jpg?5dda7ebe3a0a47b731bc018fa5259827222aab62" title="jross1972" alt="">
      </a>
    </div>
    <div class="comment_text">
      <h4>
        <a class="user" id="user_23804" href="/users/jross1972/" title="jross1972">
        
           Joe Ross
        
        </a>
        <span class="datetime"><a href="#c2691190">14 hours ago</a></span>
      </h4>

      

      
        <div><p>You're the dumbest; posting the most thoughtless, dim-witted comments ever. </p>
<p>...come at me, bro.</p></div>
      

      

<div class="vote_box">
       
          <div class="vote_form single"><a class="upvote" href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/"><span class="vote_count">3</span></a></div>
        
</div>

      
      
        
        <div class="reply_form_wrapper" style="display:none;">
         
        </div>
      
      <ul class="footer">
        
          
            <li class="signin"><a href="#login">Sign in to reply</a></li>
          
        
        
          
          
            <li class="suggest_removal"><a href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/">Sign in to suggest removal</a>
</li>
          
        
        
      </ul>
    </div>
  


</div>

     
     <!-- count: 4 -->
        




<div class="item comment comment_reply comment_depth_3" id="c2691194">
  
  
  
  
  
    
        
    
    <div class="avatar">
      <a rel="none" class="avatar_link" href="/users/DaleRogers01/">
        <img class="avatar_img" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/images/avatars/blank_avatar.gif" title="DaleRogers01" alt="">
      </a>
    </div>
    <div class="comment_text">
      <h4>
        <a class="user" id="user_316243" href="/users/DaleRogers01/" title="DaleRogers01">
        
           Dale Rogers
        
        </a>
        <span class="datetime"><a href="#c2691194">13 hours, 35 minutes ago</a></span>
      </h4>

      

      
        <p>Ignore him. He's obviously covered in the same slime as his hero, Calipari. There's a coach who proved that signing a ton of OAD's can cause you to get blown out in the first round of the NIT by a no-name school.</p>
      

      

<div class="vote_box">
       
          <div class="vote_form single"><a class="upvote" href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/"><span class="vote_count">0</span></a></div>
        
</div>

      
      
        
        <div class="reply_form_wrapper" style="display:none;">
         
        </div>
      
      <ul class="footer">
        
          
            <li class="signin"><a href="#login">Sign in to reply</a></li>
          
        
        
          
          
            <li class="suggest_removal"><a href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/">Sign in to suggest removal</a>
</li>
          
        
        
      </ul>
    </div>
  


</div>

     
     <!-- count: 5 -->
        




<div class="item comment comment_reply comment_depth_3" id="c2691208">
  
  
  
  
  
    
        
    
    <div class="avatar">
      <a rel="none" class="avatar_link" href="/users/tetsuwanatom/">
        <img class="avatar_img" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/images/avatars/blank_avatar.gif" title="tetsuwanatom" alt="">
      </a>
    </div>
    <div class="comment_text">
      <h4>
        <a class="user" id="user_74604" href="/users/tetsuwanatom/" title="tetsuwanatom">
        
           Tom Ballew
        
        </a>
        <span class="datetime"><a href="#c2691208">8 hours, 2 minutes ago</a></span>
      </h4>

      

      
        <p>Looks like sarcasm.</p>
      

      

<div class="vote_box">
       
          <div class="vote_form single"><a class="upvote" href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/"><span class="vote_count">0</span></a></div>
        
</div>

      
      
        
        <div class="reply_form_wrapper" style="display:none;">
         
        </div>
      
      <ul class="footer">
        
          
            <li class="signin"><a href="#login">Sign in to reply</a></li>
          
        
        
          
          
            <li class="suggest_removal"><a href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/">Sign in to suggest removal</a>
</li>
          
        
        
      </ul>
    </div>
  


</div>

     
     <!-- count: 6 -->
        




<div class="item comment  comment_depth_1" id="c2691185">
  
  
  
  
  
    
        
    
    <div class="avatar">
      <a rel="none" class="avatar_link" href="/users/RockHawk08/">
        <img class="avatar_img" src="http://worldonline.media.clients.ellingtoncms.com/img/profiles/2011/Jun/29/jay_tat_r48x48.jpg?5dda7ebe3a0a47b731bc018fa5259827222aab62" title="RockHawk08" alt="">
      </a>
    </div>
    <div class="comment_text">
      <h4>
        <a class="user" id="user_199876" href="/users/RockHawk08/" title="RockHawk08">
        
           Glen Miller
        
        </a>
        <span class="datetime"><a href="#c2691185">15 hours, 20 minutes ago</a></span>
      </h4>

      

      
        <p>The less Freshmen we rely on the better our teams are, that's just the cold hard facts. We all get wrapped up in recruiting, rightfully so...... but having Doke and Dotson back and getting SDS cleared are all stabilizing forces that 3 freshmen wouldn't have given us. All of Self's Final Four teams have had veteran leadership to go along with some good young talent. Even at Illinois..... so count me as one who was bummed to lose out on some recruits, yet much more optimistic now with some key pieces coming back. </p>
      

      

<div class="vote_box">
       
          <div class="vote_form single"><a class="upvote" href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/"><span class="vote_count">4</span></a></div>
        
</div>

      
      
        
        <div class="reply_form_wrapper" style="display:none;">
         
        </div>
      
      <ul class="footer">
        
          
            <li class="signin"><a href="#login">Sign in to reply</a></li>
          
        
        
          
          
            <li class="suggest_removal"><a href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/">Sign in to suggest removal</a>
</li>
          
        
        
      </ul>
    </div>
  


</div>

     
     <!-- count: 7 -->
        




<div class="item comment comment_reply comment_depth_2" id="c2691200">
  
  
  
  
  
    
        
    
    <div class="avatar">
      <a rel="none" class="avatar_link" href="/users/carsonc30/">
        <img class="avatar_img" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/images/avatars/blank_avatar.gif" title="carsonc30" alt="">
      </a>
    </div>
    <div class="comment_text">
      <h4>
        <a class="user" id="user_351309" href="/users/carsonc30/" title="carsonc30">
        
           Craig Carson
        
        </a>
        <span class="datetime"><a href="#c2691200">10 hours, 36 minutes ago</a></span>
      </h4>

      

      
        <p>Selfs best teams haven't been led by freshmen, which is a great thing ...but it was however a little unusual to see him miss out on every top recruit he went for..especially guys like Earl and Hurt since he spent years recruiting them and they were seen as KU locks...</p>
      

      

<div class="vote_box">
       
          <div class="vote_form single"><a class="upvote" href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/"><span class="vote_count">0</span></a></div>
        
</div>

      
      
        
        <div class="reply_form_wrapper" style="display:none;">
         
        </div>
      
      <ul class="footer">
        
          
            <li class="signin"><a href="#login">Sign in to reply</a></li>
          
        
        
          
          
            <li class="suggest_removal"><a href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/">Sign in to suggest removal</a>
</li>
          
        
        
      </ul>
    </div>
  


</div>

     
     <!-- count: 8 -->
        




<div class="item comment comment_reply comment_depth_3" id="c2691212">
  
  
  
  
  
    
        
    
    <div class="avatar">
      <a rel="none" class="avatar_link" href="/users/Marius7782/">
        <img class="avatar_img" src="http://worldonline.media.clients.ellingtoncms.com/img/profiles/2018/Nov/10/giphy_r48x48.gif?5dda7ebe3a0a47b731bc018fa5259827222aab62" title="Marius7782" alt="">
      </a>
    </div>
    <div class="comment_text">
      <h4>
        <a class="user" id="user_326824" href="/users/Marius7782/" title="Marius7782">
        
           Marius Rowlanski
        
        </a>
        <span class="datetime"><a href="#c2691212">7 hours, 22 minutes ago</a></span>
      </h4>

      

      
        <div><p>Basically, Self's worst recruiting class has been saved by returning players. That's not a strategy for going forward.</p>
<p>Teams are already signing players for the 2020/21 season.</p></div>
      

      

<div class="vote_box">
       
          <div class="vote_form single"><a class="upvote" href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/"><span class="vote_count">0</span></a></div>
        
</div>

      
      
        
        <div class="reply_form_wrapper" style="display:none;">
         
        </div>
      
      <ul class="footer">
        
          
            <li class="signin"><a href="#login">Sign in to reply</a></li>
          
        
        
          
          
            <li class="suggest_removal"><a href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/">Sign in to suggest removal</a>
</li>
          
        
        
      </ul>
    </div>
  


</div>

     
     <!-- count: 9 -->
        




<div class="item comment comment_reply comment_depth_4" id="c2691215">
  
  
  
  
  
    
        
    
    <div class="avatar">
      <a rel="none" class="avatar_link" href="/users/carsonc30/">
        <img class="avatar_img" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/images/avatars/blank_avatar.gif" title="carsonc30" alt="">
      </a>
    </div>
    <div class="comment_text">
      <h4>
        <a class="user" id="user_351309" href="/users/carsonc30/" title="carsonc30">
        
           Craig Carson
        
        </a>
        <span class="datetime"><a href="#c2691215">6 hours, 48 minutes ago</a></span>
      </h4>

      

      
        <p>Exactly...landing 3 4 star kids is still pretty solid but it doesn't look as good when you strike out on every other top target...Self certainly can't afford to have this type of recruiting issue next season..especially since we could see another mass exodus....are they really about to go into next season with 3 open scholarships? That seems like a bit much for a program like KU</p>
      

      

<div class="vote_box">
       
          <div class="vote_form single"><a class="upvote" href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/"><span class="vote_count">0</span></a></div>
        
</div>

      
      
        
        <div class="reply_form_wrapper" style="display:none;">
         
        </div>
      
      <ul class="footer">
        
          
            <li class="signin"><a href="#login">Sign in to reply</a></li>
          
        
        
          
          
            <li class="suggest_removal"><a href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/">Sign in to suggest removal</a>
</li>
          
        
        
      </ul>
    </div>
  


</div>

     
     <!-- count: 10 -->
        




<div class="item comment  comment_depth_1" id="c2691191">
  
  
  
  
  
    
        
    
    <div class="avatar">
      <a rel="none" class="avatar_link" href="/users/jross1972/">
        <img class="avatar_img" src="http://worldonline.media.clients.ellingtoncms.com/img/profiles/2013/May/31/_profile_r48x48.jpg?5dda7ebe3a0a47b731bc018fa5259827222aab62" title="jross1972" alt="">
      </a>
    </div>
    <div class="comment_text">
      <h4>
        <a class="user" id="user_23804" href="/users/jross1972/" title="jross1972">
        
           Joe Ross
        
        </a>
        <span class="datetime"><a href="#c2691191">13 hours, 58 minutes ago</a></span>
      </h4>

      

      
        <div><p>RE: "And, for my money, having those three players back in a Kansas uniform is a far bigger win for the Jayhawks than if they had landed Hurt, JRE and Stanley to begin with."</p>
<p>Yeah, but having that trio AND a mix of talented freshman would have been a far bigger win for the Jayhawks than the current situation.  I mean it didn't happen, sure. But you can't begrudge the begrudging. </p></div>
      

      

<div class="vote_box">
       
          <div class="vote_form single"><a class="upvote" href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/"><span class="vote_count">0</span></a></div>
        
</div>

      
      
        
        <div class="reply_form_wrapper" style="display:none;">
         
        </div>
      
      <ul class="footer">
        
          
            <li class="signin"><a href="#login">Sign in to reply</a></li>
          
        
        
          
          
            <li class="suggest_removal"><a href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/">Sign in to suggest removal</a>
</li>
          
        
        
      </ul>
    </div>
  


</div>

     
     <!-- count: 11 -->
        




<div class="item comment comment_reply comment_depth_2" id="c2691198">
  
  
  
  
  
    
        
    
    <div class="avatar">
      <a rel="none" class="avatar_link" href="/users/JayScott/">
        <img class="avatar_img" src="http://worldonline.media.clients.ellingtoncms.com/img/profiles/2019/Jan/22/si%20anastasia_r48x48.jpg?5dda7ebe3a0a47b731bc018fa5259827222aab62" title="JayScott" alt="">
      </a>
    </div>
    <div class="comment_text">
      <h4>
        <a class="user" id="user_339985" href="/users/JayScott/" title="JayScott">
        
           Jay Scott
        
        </a>
        <span class="datetime"><a href="#c2691198">12 hours, 6 minutes ago</a></span>
      </h4>

      

      
        <div><p>It's so funny when someone makes fun of fans with crazy unrealistic expectations and then, boom, someone makes the exact kind on nonsensical comment that has just been mocked....</p>
<p>Lemme help you look less clueless Joe....</p>
<p>OAD minded players WON'T sign at a school where there are already entrenched players of NBA draft caliber at their position. (actual position, not Joe Ross Axiom position) </p>
<p>That was the humor in mocking the Chicken Littles who expect HCBS to sign all the best OAD players and then also have senior laden teams. There's only 13 scholarships, five players on the floor and one ball Joe. JRE and Hurt weren't interested in competing with Lawson and De Sousa, Mac and Dok for playing time. Agbaji presents a similar roadblock (as does Garrett and did Grimes) for Stanley. </p>
<p>That's just how it works Joe.</p>
<p>Thanks for volunteering to be the perfect example of a Chicken Little. </p></div>
      

      

<div class="vote_box">
       
          <div class="vote_form single"><a class="upvote" href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/"><span class="vote_count">0</span></a></div>
        
</div>

      
      
        
        <div class="reply_form_wrapper" style="display:none;">
         
        </div>
      
      <ul class="footer">
        
          
            <li class="signin"><a href="#login">Sign in to reply</a></li>
          
        
        
          
          
            <li class="suggest_removal"><a href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/">Sign in to suggest removal</a>
</li>
          
        
        
      </ul>
    </div>
  


</div>

     
     <!-- count: 12 -->
        




<div class="item comment  comment_depth_1" id="c2691193">
  
  
  
  
  
    
        
    
    <div class="avatar">
      <a rel="none" class="avatar_link" href="/users/bb73/">
        <img class="avatar_img" src="http://worldonline.media.clients.ellingtoncms.com/img/profiles/2014/Jan/18/Dr%20Allen%201952_r48x48.jpg?5dda7ebe3a0a47b731bc018fa5259827222aab62" title="bb73" alt="">
      </a>
    </div>
    <div class="comment_text">
      <h4>
        <a class="user" id="user_70111" href="/users/bb73/" title="bb73">
        
           Steve Corder
        
        </a>
        <span class="datetime"><a href="#c2691193">13 hours, 38 minutes ago</a></span>
      </h4>

      

      
        <p>Well written, Matt. Spot-0n!</p>
      

      

<div class="vote_box">
       
          <div class="vote_form single"><a class="upvote" href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/"><span class="vote_count">0</span></a></div>
        
</div>

      
      
        
        <div class="reply_form_wrapper" style="display:none;">
         
        </div>
      
      <ul class="footer">
        
          
            <li class="signin"><a href="#login">Sign in to reply</a></li>
          
        
        
          
          
            <li class="suggest_removal"><a href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/">Sign in to suggest removal</a>
</li>
          
        
        
      </ul>
    </div>
  


</div>

     
     <!-- count: 13 -->
        




<div class="item comment  comment_depth_1" id="c2691195">
  
  
  
  
  
    
        
    
    <div class="avatar">
      <a rel="none" class="avatar_link" href="/users/OakvilleJHawk/">
        <img class="avatar_img" src="http://worldonline.media.clients.ellingtoncms.com/img/profiles/2011/Sep/13/Sept.%20bdays11%20006_r48x48.JPG?5dda7ebe3a0a47b731bc018fa5259827222aab62" title="OakvilleJHawk" alt="">
      </a>
    </div>
    <div class="comment_text">
      <h4>
        <a class="user" id="user_52284" href="/users/OakvilleJHawk/" title="Tony Bandle">
        
           Tony Bandle
        
        </a>
        <span class="datetime"><a href="#c2691195">13 hours, 25 minutes ago</a></span>
      </h4>

      

      
        <p>Matt, any word on how Mr. Wilson's visit went? I know the standard line will be everything went great, but is there any core vibe coming from the coaching staff???</p>
      

      

<div class="vote_box">
       
          <div class="vote_form single"><a class="upvote" href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/"><span class="vote_count">1</span></a></div>
        
</div>

      
      
        
        <div class="reply_form_wrapper" style="display:none;">
         
        </div>
      
      <ul class="footer">
        
          
            <li class="signin"><a href="#login">Sign in to reply</a></li>
          
        
        
          
          
            <li class="suggest_removal"><a href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/">Sign in to suggest removal</a>
</li>
          
        
        
      </ul>
    </div>
  


</div>

     
     <!-- count: 14 -->
        




<div class="item comment  comment_depth_1" id="c2691196">
  
  
  
  
  
    
        
    
    <div class="avatar">
      <a rel="none" class="avatar_link" href="/users/JayScott/">
        <img class="avatar_img" src="http://worldonline.media.clients.ellingtoncms.com/img/profiles/2019/Jan/22/si%20anastasia_r48x48.jpg?5dda7ebe3a0a47b731bc018fa5259827222aab62" title="JayScott" alt="">
      </a>
    </div>
    <div class="comment_text">
      <h4>
        <a class="user" id="user_339985" href="/users/JayScott/" title="JayScott">
        
           Jay Scott
        
        </a>
        <span class="datetime"><a href="#c2691196">12 hours, 19 minutes ago</a></span>
      </h4>

      

      
        <div><p>Such a thrill to see Joe Ross return from his self imposed exile!</p>
<p>Joe! Any thoughts on how the Joe Ross Axiom impacts this year's Jayhawks NBA draft potential?</p>
<p>As it turns out, your rabid insistence that Perry Ellis played the same position, had the same skills and should expect the same draft slot and NBA career as Max Contract SF Harrison Barnes solely because they're the same height and weight ...seems not to have panned out.....</p>
<p>Who do you see as Dedric Lawson's Joe Ross Axiom comparison? Larry Bird? Kevin Durant? Zdeno Chara? </p>
<p>Can't wait for more of your "wisdom" Joe.....make sure to include the misquoted scripture and Doobie Brothers lyrics. That's the icing on your fruitcake.</p></div>
      

      

<div class="vote_box">
       
          <div class="vote_form single"><a class="upvote" href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/"><span class="vote_count">0</span></a></div>
        
</div>

      
      
        
        <div class="reply_form_wrapper" style="display:none;">
         
        </div>
      
      <ul class="footer">
        
          
            <li class="signin"><a href="#login">Sign in to reply</a></li>
          
        
        
          
          
            <li class="suggest_removal"><a href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/">Sign in to suggest removal</a>
</li>
          
        
        
      </ul>
    </div>
  


</div>

     
     <!-- count: 15 -->
        




<div class="item comment  comment_depth_1" id="c2691197">
  
  
  
  
  
    
        
    
    <div class="avatar">
      <a rel="none" class="avatar_link" href="/users/dmudd/">
        <img class="avatar_img" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/images/avatars/blank_avatar.gif" title="dmudd" alt="">
      </a>
    </div>
    <div class="comment_text">
      <h4>
        <a class="user" id="user_76070" href="/users/dmudd/" title="dmudd">
        
           Dwayne Mudd
        
        </a>
        <span class="datetime"><a href="#c2691197">12 hours, 10 minutes ago</a></span>
      </h4>

      

      
        <div><p>Amen Brother…  I rewatched the 2018 Elite 8 game vs Duke last night.  We return the entire frontcourt from that team.....Plus now we got DMac..  That is a sic frontcourt folks...</p>
<p>Dok is Dok and he is a beast.  But I was watching DeSousa.  That dude is quick quick quick.....  That is the skill that he brings that DMac and Dok don't have so much.... He runs the floor like a deer, effortlessly slides his feet, and is strong as a oxe....And that smooth smooth free throw stroke...  This 4-Headed monster of a front line is going to be a force to be reckoned with....  Let's don't forget Mitch... He gets overlooked but he is going to be senior and he is a tough, hustling, pick sitting, charge taking, shot blocking baller!!!!!!!!!!!  Go Hawks!!!!  Beware of the Phog Big 12 foes!!!</p></div>
      

      

<div class="vote_box">
       
          <div class="vote_form single"><a class="upvote" href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/"><span class="vote_count">2</span></a></div>
        
</div>

      
      
        
        <div class="reply_form_wrapper" style="display:none;">
         
        </div>
      
      <ul class="footer">
        
          
            <li class="signin"><a href="#login">Sign in to reply</a></li>
          
        
        
          
          
            <li class="suggest_removal"><a href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/">Sign in to suggest removal</a>
</li>
          
        
        
      </ul>
    </div>
  


</div>

     
     <!-- count: 16 -->
        




<div class="item comment comment_reply comment_depth_2" id="c2691202">
  
  
  
  
  
    
        
    
    <div class="avatar">
      <a rel="none" class="avatar_link" href="/users/carsonc30/">
        <img class="avatar_img" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/images/avatars/blank_avatar.gif" title="carsonc30" alt="">
      </a>
    </div>
    <div class="comment_text">
      <h4>
        <a class="user" id="user_351309" href="/users/carsonc30/" title="carsonc30">
        
           Craig Carson
        
        </a>
        <span class="datetime"><a href="#c2691202">10 hours, 22 minutes ago</a></span>
      </h4>

      

      
        <p>The front court is gonna be a handful for opponents all year...if they can combine that with reliable enough outside shooting then they have a shot at a FF or more...I just hope Garrett has worked on his 3 pt shot..</p>
      

      

<div class="vote_box">
       
          <div class="vote_form single"><a class="upvote" href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/"><span class="vote_count">0</span></a></div>
        
</div>

      
      
        
        <div class="reply_form_wrapper" style="display:none;">
         
        </div>
      
      <ul class="footer">
        
          
            <li class="signin"><a href="#login">Sign in to reply</a></li>
          
        
        
          
          
            <li class="suggest_removal"><a href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/">Sign in to suggest removal</a>
</li>
          
        
        
      </ul>
    </div>
  


</div>

     
     <!-- count: 17 -->
        




<div class="item comment  comment_depth_1" id="c2691211">
  
  
  
  
  
    
        
    
    <div class="avatar">
      <a rel="none" class="avatar_link" href="/users/Marius7782/">
        <img class="avatar_img" src="http://worldonline.media.clients.ellingtoncms.com/img/profiles/2018/Nov/10/giphy_r48x48.gif?5dda7ebe3a0a47b731bc018fa5259827222aab62" title="Marius7782" alt="">
      </a>
    </div>
    <div class="comment_text">
      <h4>
        <a class="user" id="user_326824" href="/users/Marius7782/" title="Marius7782">
        
           Marius Rowlanski
        
        </a>
        <span class="datetime"><a href="#c2691211">7 hours, 25 minutes ago</a></span>
      </h4>

      

      
        <div><p>Not to beat a dead horse but what happened to the supposed uptick in Kansas recruiting?</p>
<p>I don't think we got a single target during either signing period that signed with Kansas. If these three haven't returned, we'd be a middle of the BIG12 somewhere watching the NCAA tournament.</p></div>
      

      

<div class="vote_box">
       
          <div class="vote_form single"><a class="upvote" href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/"><span class="vote_count">0</span></a></div>
        
</div>

      
      
        
        <div class="reply_form_wrapper" style="display:none;">
         
        </div>
      
      <ul class="footer">
        
          
            <li class="signin"><a href="#login">Sign in to reply</a></li>
          
        
        
          
          
            <li class="suggest_removal"><a href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/">Sign in to suggest removal</a>
</li>
          
        
        
      </ul>
    </div>
  


</div>

     
     <!-- count: 18 -->
        




<div class="item comment comment_reply comment_depth_2" id="c2691216">
  
  
  
  
  
    
        
    
    <div class="avatar">
      <a rel="none" class="avatar_link" href="/users/carsonc30/">
        <img class="avatar_img" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/images/avatars/blank_avatar.gif" title="carsonc30" alt="">
      </a>
    </div>
    <div class="comment_text">
      <h4>
        <a class="user" id="user_351309" href="/users/carsonc30/" title="carsonc30">
        
           Craig Carson
        
        </a>
        <span class="datetime"><a href="#c2691216">6 hours, 46 minutes ago</a></span>
      </h4>

      

      
        <p>I think they still make the NCAA but that's about it</p>
      

      

<div class="vote_box">
       
          <div class="vote_form single"><a class="upvote" href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/"><span class="vote_count">0</span></a></div>
        
</div>

      
      
        
        <div class="reply_form_wrapper" style="display:none;">
         
        </div>
      
      <ul class="footer">
        
          
            <li class="signin"><a href="#login">Sign in to reply</a></li>
          
        
        
          
          
            <li class="suggest_removal"><a href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/">Sign in to suggest removal</a>
</li>
          
        
        
      </ul>
    </div>
  


</div>

     
     <!-- count: 19 -->
        




<div class="item comment  comment_depth_1" id="c2691224">
  
  
  
  
  
    
        
    
    <div class="avatar">
      <a rel="none" class="avatar_link" href="/users/surrealKU/">
        <img class="avatar_img" src="http://worldonline.media.clients.ellingtoncms.com/img/profiles/2019/Feb/09/DycDfK9UwAEfXMm_mMgE3sE_r48x48.jpg?5dda7ebe3a0a47b731bc018fa5259827222aab62" title="surrealKU" alt="">
      </a>
    </div>
    <div class="comment_text">
      <h4>
        <a class="user" id="user_287604" href="/users/surrealKU/" title="surrealKU">
        
           Steve Zimmerman
        
        </a>
        <span class="datetime"><a href="#c2691224">2 hours, 59 minutes ago</a></span>
      </h4>

      

      
        <p>I think we undermine Dok's injury. While I wish him 1000% fully recovered and healthier, he has yet to prove that he's back in action during practices. He can probably dominate Lightfoot but handling Silvio is not that easy. Twice fractured wrist will never feel the same. Plus the trauma effect, and he has yet to be tested in a real college game. One thing that will help his draft stock is improvement in stamina, FT shooting, BLOCKS &amp; REBOUNDS. That's a lot, I know. But nothing is impossible. </p>
      

      

<div class="vote_box">
       
          <div class="vote_form single"><a class="upvote" href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/"><span class="vote_count">0</span></a></div>
        
</div>

      
      
        
        <div class="reply_form_wrapper" style="display:none;">
         
        </div>
      
      <ul class="footer">
        
          
            <li class="signin"><a href="#login">Sign in to reply</a></li>
          
        
        
          
          
            <li class="suggest_removal"><a href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/">Sign in to suggest removal</a>
</li>
          
        
        
      </ul>
    </div>
  


</div>

      
  
 </div>
    

      
    
  

  
  

  
    
      
      
        




  <h3>Sign in to comment</h3>
  



<div id="login">
 <a style="display: inline-block; margin: 20px 0px;" class="button" href="/accounts/login/?next=/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/">Login/Signup</a>
</div>



      
    
  
</div>





            </div><!-- .content -->
          
        </div><!-- #content-wrapper -->

        
          <div class="section_sidebar">
            
<ul class="parent-tools tools">
  
    
      <li class="subscribe"><a href="/weblogs/tale-tait/feed/"><small>Subscribe to</small> Tale of the Tait entries via RSS</a></li>  
    
  
</ul>

          </div>
          <hr class="section_hr">
        
      </div><!-- #section_wrapper -->

      
        <div id="sidebar">
          
            
  
  <div class="post_tools">

  
    
  

  
  

  
    
      
    
      <p><a class="button" href="#comment_form">Reply</a>
        
          
          <a href="#comments">19 comments</a> from
          
            
              <img class="avatar_img" src="http://worldonline.media.clients.ellingtoncms.com/img/profiles/2019/Feb/09/DycDfK9UwAEfXMm_mMgE3sE_r18x18.jpg?5e26a4b3fc50822f30b690b36ea3da5d8dc6e1b5" title="Surrealku" alt="Surrealku">
            
          
            
              <img class="avatar_img" src="http://media.lawrence.com/img/profiles/default_avatars/blank_avatar_r18x18.png?5e26a4b3fc50822f30b690b36ea3da5d8dc6e1b5" title="Carsonc30" alt="Carsonc30">
            
          
            
              <img class="avatar_img" src="http://worldonline.media.clients.ellingtoncms.com/img/profiles/2018/Nov/10/giphy_r18x18.gif?5e26a4b3fc50822f30b690b36ea3da5d8dc6e1b5" title="Marius7782" alt="Marius7782">
            
          
            
              <img class="avatar_img" src="http://media.lawrence.com/img/profiles/default_avatars/blank_avatar_r18x18.png?5e26a4b3fc50822f30b690b36ea3da5d8dc6e1b5" title="Tom Ballew" alt="Tom Ballew">
            
          
            
              <img class="avatar_img" src="http://worldonline.media.clients.ellingtoncms.com/img/profiles/2019/Jan/22/si%20anastasia_r18x18.jpg?5e26a4b3fc50822f30b690b36ea3da5d8dc6e1b5" title="Jayscott" alt="Jayscott">
            
          
        
      
        
          and 7 others
        
      </p>
    
  
    
      
    
  
  </div> 



            
            <div id="primary_ad">
              
	
                <div class="ad"> 
 <div class="spot">
   <div id='div-gpt-ad-1427129310758-1' class="ad">
    <script type='text/javascript'>
     googletag.cmd.push(function() { googletag.display('div-gpt-ad-1427129310758-1'); });
    </script>
   </div>
 </div>
</div> 

              

  
      
      <div class="ad" style="background: #fff; padding: 15px;">
        <div class="taboola">
	<div id="taboola-right-rail-article-thumbnails"></div>
	<script type="text/javascript">
	  window._taboola = window._taboola || [];
	  _taboola.push({
	    mode: 'alternating-thumbnails-rr',
	    container: 'taboola-right-rail-article-thumbnails',
	    placement: 'Right Rail Article Thumbnails',
	    target_type: 'mix'
	  });
	</script>
</div>
      </div>

            </div>
            

            <div id="sidebar_secondary">
              
              <div class="deals_widget">
	<style>
		.deals_widget { margin-bottom: 30px; }
    	.deals_widget h2 { font-size: 27px; margin: 12px 0; }
    	.deals_widget p { font-size: 14px; line-height: 21px; margin-bottom: 15px; }
    	#nimbleBuyWidget15812 { background: #fff; }
	</style>
	<div id='div-gpt-ad-1427129310758-16'>
		<script type='text/javascript'>
			googletag.cmd.push(function() { googletag.display('div-gpt-ad-1427129310758-16'); });
		</script>
	</div>
</div>

              
  
  
    <div class="module tag_module">
      <h3>Tags</h3>
      <ol class="tag_list">
        
          <li>
            
              <a class="tag" href="/weblogs/tale-tait/tags/ku-basketball_1/">KU basketball</a>
            
          </li>
        
          <li>
            
              <a class="tag" href="/weblogs/tale-tait/tags/2019-20-season/">2019-20 season</a>
            
          </li>
        
      </ol>
    </div>
  


            </div>

            <div id="sidebar_main" class="sidebar">
              
<!-- from weblobs base-->



<div class="module sidebar_content">
  <div class="wrapper">    
  <h2 class="top"><a href="/weblogs/tale-tait/">More from Tale of the Tait</a></h2>
  <ul>
    
    <li><a href="/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/"><small>June 4</small> Key trio of returing Jayhawks far better than any group Kansas could&#39;ve landed</a></li>
    
    <li><a href="/weblogs/tale-tait/2019/jun/3/ku-basketballs-self-made-tbt-roster-near/"><small>June 3</small> KU basketball&#39;s Self Made TBT roster nearing completion</a></li>
    
    <li><a href="/weblogs/tale-tait/2019/may/31/nick-collison-perry-ellis-honored-by-sep/"><small>May 31</small> Nick Collison, Perry Ellis honored by separate Kansas Halls of Fame</a></li>
    
    <li><a href="/weblogs/tale-tait/2019/may/30/one-day-back-ku-point-guard-devon-dotson/"><small>May 30</small> One day back, KU point guard Devon Dotson appears to be contemplating a number change</a></li>
    
    <li><a href="/weblogs/tale-tait/2019/may/30/after-heavy-freshman-feel-in-2018-19-kan/"><small>May 30</small> After heavy freshman feel in 2018-19, Kansas basketball likely moving back toward a veteran lineup</a></li>
    
    <li><a href="/weblogs/tale-tait/2019/may/29/say-what-taits-weekly-appearance-on-rock/"><small>May 29</small> Say What? Tait&#39;s Weekly Appearance on Rock Chalk Sports Talk</a></li>
    
    <li><a href="/weblogs/tale-tait/2019/may/29/nbl-commissioner-says-landing-rj-hampton/"><small>May 29</small> NBL commissioner says landing R.J. Hampton is no sign of looming threat to NBA or college basketball</a></li>
    
    <li><a href="/weblogs/tale-tait/2019/may/28/whats-next-for-ku-with-rj-hampton-now-of/"><small>May 28</small> What&#39;s next for KU with R.J. Hampton now off the board? </a></li>
    
    <li><a href="/weblogs/tale-tait/2019/may/26/reports-surface-of-kansas-basketball-add/"><small>May 26</small> Kansas basketball program adding walk-on shooting guard with a familiar last name</a></li>
    
    <li><a href="/weblogs/tale-tait/2019/may/24/rj-hampton-sets-date-for-college-announc/"><small>May 24</small> R.J. Hampton sets date for college announcement</a></li>
    
  </ul>
  </div>
</div>



            </div>

            <div id="secondary_ad">
              
                <div class="ad">
  <p><small>Advertisement</small></p>
  <div class="spot">
     <div id='div-gpt-ad-1427129310758-4' style='width:300px; height:250px;'>
       <script type='text/javascript'>
          googletag.cmd.push(function() { googletag.display('div-gpt-ad-1427129310758-4'); });
       </script>
     </div> 
  </div>
</div>

              
            </div>

            <div id='div-gpt-ad-1427129310758-17'>
              <script type='text/javascript'>
                googletag.cmd.push(function() { googletag.display('div-gpt-ad-1427129310758-17'); });
              </script>
            </div>
            <!-- /1024221/KUS_OOP -->
            <div id='div-gpt-ad-1427129310758-18'>
              <script>
                googletag.cmd.push(function() { googletag.display('div-gpt-ad-1427129310758-18'); });
              </script>
            </div>

            <div id="sidebar_post">
              
            </div>
          
        </div><!-- #sidebar -->
      

      <div class="clear"></div> 
    
  </div><!-- #body -->

  <div id="footer">

    
      <div class="nav">
        




  
  
  
  
  
  

  <div class="col">
    <h4>You</h4>
    <ul>
      
      <li><a href="/accounts/login/">Login / Sign up</a></li>
      
    </ul>

    <h4>KU Fans</h4>
<ul>
  <li><a href="/polls/">Polls</a></li>
  <li><a href="/discussions/">Discussions</a></li>
  <li><a href="/photos/galleries/sets/fan_photos/">Fan Photos</a></li>
  <li><a href="http://boards.kusports.com">Message boards</a></li>
  <li><a href="https://www.facebook.com/KUsportsdotcom/">Facebook</a></li>
  <li><a href="http://twitter.com/kusports/">Twitter</a></li>
</li></ul>
  </div>

  <div class="col">
    <h4>Essentials</h4>
<ul>
	<li><a href="http://www2.ljworld.com/news/champions2008/">Self-made Champions</a></li>
	<li><a href="https://shop.ljworld.com/">Merchandise</a></li>
	<li><a href="/news/columns/">Columns</a></li>
	<li><a href="/weblogs/staff/">Blogs</a></li>
	<li><a href="/schedules/">Schedules</a></li>
	<li><a href="/chats/archive/">Chat transcripts</a></li>
	<li><a href="https://seatgeek.com/kansas-jayhawks-basketball-tickets?aid=12341" onClick="_gaq.push(['_trackEvent', 'Tickets', 'KUS_footer', 'kusports.com']);">Tickets</a></li>
        <li><a href="https://geo.itunes.apple.com/us/app/kusports.com/id389444893?mt=8">iPhone App</a></li>
        <li><a href="https://play.google.com/store/apps/details?id=com.whiz.kusports">Android App</a></li>

</ul>
  </div>

  <div class="col">
    <h4>Multimedia</h4>
<ul>
	<li><a href="/videos/">Videos</a></li>
	<li><a href="/podcasts/">Podcasts</a></li>
	<li><a href="/photos/">Photos</a></li>
	<li><a href="/photos/galleries/sets/">Photo galleries</a></li>
	<li><a href="/audioclips/">Audio</a></li>
</ul>
<h4>Miscellaneous</h4>
<ul>
  <li><a href="/destinations/road-hawks/">KU fan travel guide</a></li>
  <li><a href="http://www.kuathletics.com/staff.aspx">KAI directory</a></li>
  <li><a href="http://www.kualumni.org/chapters/watchsites/">KU Alumni Assoc. Watch Party Sites</a></li>
</ul>
  </div>

  <div class="col">
      <h4>Football</h4>
  <ul>	
    <li><a href="/news/football/">Full coverage</a></li>
    <li><a href="/schedules/football/2017/kansas/">’17 Schedule</a></li>
    <li><a href="http://www2.kusports.com/documents/2017/jul/21/2017-kansas-football-roster/">’17 Roster</a></li>
    <li><a href="http://boards.kusports.com/ubb/postlist.php?Cat=&amp;Board=football">Message Boards</a></li>
    <li><a href="/news/football/2008/orange_bowl/">’08 Orange Bowl</a></li>
    <li><a href="/news/football/recruiting">Recruiting</a></li>
    <li><a href="/football/virtual_stadium_seating2/">Virtual Memorial Stadium</a></li>
    <li><a href="/news/football/hawks_nfl/">’Hawks in the NFL</a></li>
    <li><a href="/hawktrax/football/">Hawktrax</a></li>
  </ul>

  </div>

  <div class="col">
    <h4>Men’s Basketball</h4>
<ul>	
<li><a href="/news/mens_basketball/">Full coverage</a></li>			
<li><a href="http://www2.kusports.com/schedules/mens-basketball/2017-18/kansas/">’17-’18 Schedule</a></li>
<li><a href="http://www2.kusports.com/documents/2017/aug/22/2017-18-kansas-mens-basketball-roster/">’17-’18 Roster</a></li>	
<li><a href="http://boards.kusports.com/ubb/postlist.php?Cat=&amp;Board=basketball">Message Boards</a></li>	
<li><a href="http://www2.ljworld.com/news/champions2008/">’08 KU National Championship</a></li>
<li><a href="/news/mens_basketball/2010-11_timeline/">2010-11 Timeline</a></li>
<li><a href="/news/mens_basketball/recruiting/">Recruiting</a></li>		
<li><a href="/news/mens_basketball/hawks_nba/">’Hawks in the NBA</a></li>
<li><a href="/hawktrax/basketball/">Hawktrax</a></li>
<li><a href="https://seatgeek.com/kansas-jayhawks-basketball-tickets?aid=12341 ">Tickets</a></li>
</ul>
  </div>

  <div class="col">
    <h4>Other Sports</h4>
<ul>	
	<li><a href="/news/womens_basketball/">Women’s Basketball</a></li>
	<li><a href="/news/baseball/">Baseball</a></li>
	<li><a href="/news/softball/">Softball</a></li>
	<li><a href="/news/track_field/">Track &amp; Field</a></li>
	<li><a href="/news/cross_country/">Cross Country</a></li>
	<li><a href="/news/mens_golf/">Men’s Golf</a></li>
	<li><a href="/news/womens_golf/">Women’s Golf</a></li>
	<li><a href="/news/soccer/">Soccer</a></li>
	<li><a href="/news/swimming/">Swimming</a></li>
	<li><a href="/news/rowing/">Rowing</a></li>
	<li><a href="/news/tennis/">Tennis</a></li>
	<li><a href="/news/volleyball/">Volleyball</a></li>
	<li><a href="/news/bowling/">Bowling</a></li>
</ul>

  </div>


      </div>

      

      
      <div id='div-gpt-ad-1427129310758-15' style='width:728px; height:90px; margin: 20px auto;'>
        <script type='text/javascript'>
          googletag.cmd.push(function() { googletag.display('div-gpt-ad-1427129310758-15'); });
        </script>
      </div>
      

      

      <p>Contents of this site are <a href="/site/copyright/">&copy; Copyright</a> 2019 by Lawrence Journal-World.</p>
      <p><a href="/site/feedback/">Site feedback</a> /
        <a href="/about_us/">About us</a> /
        <a href="/site/contact/">Contact Us</a> /
        <a href="/site/rules/">Terms of service</a> /
        <a href="/legal/dmca/"><span class="caps">DMCA</span> Notice</a> /
        <a href="/site/advertise/">Advertise</a> /
        <a href="https://rn12.ultipro.com/WOR1007/JobBoard/ListJobs.aspx?__vt=ExtCan">Jobs</a></p>
    
  </div><!-- #footer -->

    </div>
    
  <div id="userhood" style="display:none">
    <div class="wrapper">
    
      <div class="hood">
        <div class="login">
          <form action="/accounts/login/" method="post" class="login_form">
            <h2>Log in to your KUsports.com account.</h2>
            <h3>You may also use your Lawrence.com or LJWorld.com&nbsp;account.</h3>
            <p><label for="id_username">Username:</label> <input id="id_username" type="text" name="username" maxlength="30" />
              </p>
            <p><label for="id_password">Password:</label> <input id="id_password" type="password" name="password" maxlength="30" />
              </p>
            <p class="submit">
              <input type="hidden" name="next" value="/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/">
              <input type="submit" value="Log in" class="button">
              <a href="/accounts/password/reset/" class="alt_button">Forgotten your password?</a>
            </p>
          </form>

          <form action="/accounts/register/" method="post" class="signup_form">
            <h2>Don’t have a KUsports.com account? Get one now!</h2>
            <h3>An account lets you join in the conversation, mark your favorites, get your own Fan Blog and more.</h3>
            <p><label for="id_email">Your email:</label>
              <input type="text" name="email" value="" id="id_email"></p>
            <p class="submit"><input type="submit" value="Sign up" class="button"></p>
          </form>
        </div>
      </div>
    
  </div>
  <div class="hood-footer"><div class="hood"><p><a href="#">Close</a></p></div></div>
  </div>


    <script type="text/javascript">
  var wol = window.wol || {};
  wol.debug = false;

  wol.site = {
      id: '4',
      name: 'KUsports.com',
      domain: 'www2.kusports.com'
  };

  wol.user = {
    id: null,
    username: '',
    first_name: '',
    last_name: '',
    email: '',
    is_anonymous: true,
    is_authenticated: false,
    is_active: false,
    is_staff: false,
    is_superuser: false,
    date_joined: ''
  };

  
  
  wol.recaptcha = {
    api_key: '6LcIaxUUAAAAANyWnGYU1FiUqTeQ4iB8ZIr9Ic_r',
    enable_blog_posts: false,
    enable_comments: false,
    enable_mailforms: true,
    enable_registration: true
  };
</script>


    

<script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/kusports.com/javascript/site.js"></script>
  
    
    
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington_defaults/2.2.0/javascript/thirdparty/jquery.ui.js"></script>
    
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/javascript/3p/lightbox_me/jquery.lightbox_me.js"></script>
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/javascript/3p/jquery.autofocus-min.js"></script>
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/javascript/wol.defaults.js?v=2"></script>
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington_default_old/javascript/jquery.media.js"></script>
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington_default_old/javascript/jquery.defaults.js"></script>
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/ellington_default_old/javascript/jquery.carousel.js"></script>
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/javascript/extended_sharingtools.js"></script>
    <script type="text/javascript" src="http://worldonline.media.clients.ellingtoncms.com/static/worldonline_defaults/javascript/repost.js"></script>
    
    <script type="text/javascript">
      $(document).ready(function() {
        $('.accordion').accordion({'autoHeight': false});
      });
    </script>
    
  

    

    
    

    
<script async src="//cdn.embedly.com/widgets/platform.js" charset="UTF-8"></script>



    
    
        <!-- Quantcast Tag -->
        <script type="text/javascript">
        var _qevents = _qevents || [];

        (function() {
        var elem = document.createElement('script');
        elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
        elem.async = true;
        elem.type = "text/javascript";
        var scpt = document.getElementsByTagName('script')[0];
        scpt.parentNode.insertBefore(elem, scpt);
        })();

        _qevents.push({
        qacct:"p-b9OfuctfLWqtE"
        });
        </script>

        <noscript>
        <div style="display:none;">
        <img src="//pixel.quantserve.com/pixel/p-b9OfuctfLWqtE.gif" border="0" height="1" width="1" alt="Quantcast"/>
        </div>
        </noscript>
        <!-- End Quantcast tag -->
    
    

    
      
      <script type='text/javascript'>
          var _sf_async_config={};
          /** CONFIGURATION START **/
          _sf_async_config.uid = 27638;
          _sf_async_config.domain = 'www2.kusports.com';
          _sf_async_config.path = '/weblogs/tale-tait/2019/jun/4/key-trio-of-returing-jayhawks-far-better/';
          
          /** CONFIGURATION END **/
          (function(){
            function loadChartbeat() {
              window._sf_endpt=(new Date()).getTime();
              var e = document.createElement('script');
              e.setAttribute('language', 'javascript');
              e.setAttribute('type', 'text/javascript');
              e.setAttribute('src',
                 (('https:' == document.location.protocol) ? 'https://a248.e.akamai.net/chartbeat.download.akamai.com/102508/' : 'http://static.chartbeat.com/') +
                 'js/chartbeat.js');
              document.body.appendChild(e);
            }
            var oldonload = window.onload;
            window.onload = (typeof window.onload != 'function') ?
               loadChartbeat : function() { oldonload(); loadChartbeat(); };
          })();
      </script>
      
    
  </body>
</html>
